View Issue Details

IDProjectCategoryView StatusLast Update
0004632Slicer4Core: Base Codepublic2018-10-15 18:23
ReporterjcfrAssigned Topieper 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004632: py_LandmarkRegistration test segfault
Description

This happens on the macOS dashboard. See http://slicer.cdash.org/testDetails.php?test=9210944&build=1399194

It is also reproducible on Linux

TagsNo tags attached.

Activities

jcfr

jcfr

2018-10-15 03:33

administrator   ~0016125

Last edited: 2018-10-15 03:39

View 6 revisions

All landmark test are passing, the issue happen on exit.

Here is the backtrace associated with the core dump:

0  0x00007fd2a4c893a0 in QArrayData::shared_null () from /home/jcfr/Software/Qt5.11.1/5.11.1/gcc_64/lib/libQt5Core.so.5
1  0x00007fd2a59d0eac in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0xa2c73c0, e=0x7fff87fb9e80) at kernel/qapplication.cpp:3727
2  0x00007fd2a59d7fe0 in QApplication::notify (this=this@entry=0x7fff87fba630, receiver=0xa2c73c0, e=0x7fff87fb9e80) at kernel/qapplication.cpp:3486
3  0x00007fd2c4f00a0c in qSlicerApplication::notify (this=0x7fff87fba630, receiver=<optimized out>, event=<optimized out>) at /home/jcfr/Projects/Slicer-Qt5-VTK9/Base/QTGUI/qSlicerApplication.cxx:396
4  0x00007fd2a4b82918 in QCoreApplication::notifyInternal2 (receiver=0xa2c73c0, event=event@entry=0x7fff87fb9e80) at kernel/qcoreapplication.cpp:1048
5  0x00007fd2a4bb4ee7 in QCoreApplication::sendEvent (event=0x7fff87fb9e80, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
6  QObjectPrivate::setParent_helper (this=this@entry=0x96fa600, o=o@entry=0x0) at kernel/qobject.cpp:2023
7  0x00007fd2a4bb5408 in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1034
8  0x00007fd2b6eb7759 in PythonQtSignalReceiver::~PythonQtSignalReceiver (this=0xc935550, __in_chrg=<optimized out>) at /home/jcfr/Projects/Slicer-Qt5-VTK9-RelWithDebInfo/CTK-build/PythonQt/src/PythonQtSignalReceiver.cpp:183
9  0x00007fd2a4bab3e3 in QObjectPrivate::deleteChildren (this=this@entry=0xa43f140) at kernel/qobject.cpp:1997
10 0x00007fd2a5a09128 in QWidget::~QWidget (this=0xa2c73c0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
11 0x00007fd2b7162ae9 in PythonQtShell_QRadioButton::~PythonQtShell_QRadioButton (this=0xa2c73c0, __in_chrg=<optimized out>) at /home/jcfr/Projects/Slicer-Qt5-VTK9-RelWithDebInfo/CTK-build/PythonQt/generated_cpp_56/com_trolltech_qt_gui/com_trolltech_qt_gui7.cpp:7359
12 0x00007fd2a4bae758 in QObject::event (this=this@entry=0xa2c73c0, e=e@entry=0xcf47610) at kernel/qobject.cpp:1242
13 0x00007fd2a5a0de13 in QWidget::event (this=0xa2c73c0, event=0xcf47610) at kernel/qwidget.cpp:9347
14 0x00007fd2a5ab7d63 in QAbstractButton::event (this=this@entry=0xa2c73c0, e=<optimized out>) at widgets/qabstractbutton.cpp:968
15 0x00007fd2a5b4b6f4 in QRadioButton::event (this=this@entry=0xa2c73c0, e=<optimized out>) at widgets/qradiobutton.cpp:261
16 0x00007fd2b71a2775 in PythonQtShell_QRadioButton::event (this=0xa2c73c0, e0=0xcf47610) at /home/jcfr/Projects/Slicer-Qt5-VTK9-RelWithDebInfo/CTK-build/PythonQt/generated_cpp_56/com_trolltech_qt_gui/com_trolltech_qt_gui7.cpp:7646
17 0x00007fd2a59d0eac in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0xa2c73c0, e=0xcf47610) at kernel/qapplication.cpp:3727
18 0x00007fd2a59d7fe0 in QApplication::notify (this=this@entry=0x7fff87fba630, receiver=0xa2c73c0, e=0xcf47610) at kernel/qapplication.cpp:3486
19 0x00007fd2c4f00a0c in qSlicerApplication::notify (this=0x7fff87fba630, receiver=<optimized out>, event=<optimized out>) at /home/jcfr/Projects/Slicer-Qt5-VTK9/Base/QTGUI/qSlicerApplication.cxx:396
20 0x00007fd2a4b82918 in QCoreApplication::notifyInternal2 (receiver=0xa2c73c0, event=event@entry=0xcf47610) at kernel/qcoreapplication.cpp:1048
21 0x00007fd2a4b8532b in QCoreApplication::sendEvent (event=0xcf47610, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
22 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=52, data=0x142cb00) at kernel/qcoreapplication.cpp:1745
23 0x00007fd2a4b85818 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=52) at kernel/qcoreapplication.cpp:1599
24 0x00007fd2a4b85861 in QCoreApplicationPrivate::execCleanup (this=<optimized out>) at kernel/qcoreapplication.cpp:1358
25 0x00007fd2a4b89c98 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1340
26 0x00007fd2a51a5d3c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1761
27 0x00007fd2a59d0e05 in QApplication::exec () at kernel/qapplication.cpp:2901
28 0x000000000040453e in (anonymous namespace)::SlicerAppMain (argv=<optimized out>, argc=9) at /home/jcfr/Projects/Slicer-Qt5-VTK9/Applications/SlicerApp/Main.cxx:62
29 main (argc=<optimized out>, argv=<optimized out>) at /home/jcfr/Projects/Slicer-Qt5-VTK9/Base/QTApp/qSlicerApplicationMainWrapper.cxx:56
jcfr

jcfr

2018-10-15 03:57

administrator   ~0016126

Last edited: 2018-10-15 03:57

View 2 revisions

The crash is not specific to closing the application, it happens after:
(1) Loading MRHead twice
(2) Opening Landmark registration and selecting MRHead and MRHead_1 as fixed and moving images
(2) Select Local Refinement to "Local BRAINSFit"
(3) Then select "Local SimpleITK"
(4) crash

Same thing happens after selecting registration types

jcfr

jcfr

2018-10-15 05:50

administrator   ~0016127

This is fixed by https://github.com/pieper/LandmarkRegistration/pull/22

jcfr

jcfr

2018-10-15 17:59

administrator   ~0016131

Fixed in r27488
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=27488

pieper

pieper

2018-10-15 18:23

administrator   ~0016132

Thanks for the fix Jc - I couldn't reproduce using the instructions you provided, so I'd say it's good to close.

Issue History

Date Modified Username Field Change
2018-10-15 03:32 jcfr New Issue
2018-10-15 03:32 jcfr Status new => assigned
2018-10-15 03:32 jcfr Assigned To => jcfr
2018-10-15 03:32 jcfr Severity minor => crash
2018-10-15 03:33 jcfr Note Added: 0016125
2018-10-15 03:34 jcfr Note Edited: 0016125 View Revisions
2018-10-15 03:34 jcfr Note Edited: 0016125 View Revisions
2018-10-15 03:34 jcfr Note Edited: 0016125 View Revisions
2018-10-15 03:35 jcfr Note Edited: 0016125 View Revisions
2018-10-15 03:39 jcfr Note Edited: 0016125 View Revisions
2018-10-15 03:57 jcfr Note Added: 0016126
2018-10-15 03:57 jcfr Note Edited: 0016126 View Revisions
2018-10-15 05:50 jcfr Note Added: 0016127
2018-10-15 05:50 jcfr Target Version => Slicer 4.9.0
2018-10-15 13:43 jcfr Assigned To jcfr => pieper
2018-10-15 17:59 jcfr Status assigned => resolved
2018-10-15 17:59 jcfr Resolution open => fixed
2018-10-15 17:59 jcfr Fixed in Version => Slicer 4.9.0
2018-10-15 17:59 jcfr Note Added: 0016131
2018-10-15 18:23 pieper Status resolved => closed
2018-10-15 18:23 pieper Note Added: 0016132