View Issue Details

IDProjectCategoryView StatusLast Update
0004633Slicer4Core: GUIpublic2018-10-15 07:53
ReporterjcfrAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004633: Fix qSlicerReformatModuleWidgetGenericTest by ensuring ctkDoubleSpinBox sizeHint is valid
Description

Setting the sizeHintPolicy of ctk.ctkCoordinatesWidget() has no effect.

In the python interactor:

c = ctk.ctkCoordinatesWidget()
print(c.sizeHintPolicy) # Default is ctk.ctkDoubleSpinBox.SizeHintByMinMax
c.show()

The widget can't be resized to a smaller size because the min/max are internally set with std::numeric_limits<double>::max().
=> This is the expected behavior

Now, update the policy:

c.sizeHintPolicy =  ctk.ctkDoubleSpinBox.SizeHintByValue

=> It should be possible to resize the widget ... but this is failing..

TagsNo tags attached.

Activities

jcfr

jcfr

2018-10-15 07:46

administrator   ~0016128

This is fixed by https://github.com/commontk/CTK/pull/838

jcfr

jcfr

2018-10-15 07:53

administrator   ~0016129

Fixed in r27485
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=27485

Issue History

Date Modified Username Field Change
2018-10-15 07:30 jcfr New Issue
2018-10-15 07:31 jcfr Description Updated View Revisions
2018-10-15 07:32 jcfr Description Updated View Revisions
2018-10-15 07:33 jcfr Description Updated View Revisions
2018-10-15 07:46 jcfr Target Version => Slicer 4.9.0
2018-10-15 07:46 jcfr Note Added: 0016128
2018-10-15 07:46 jcfr Assigned To => jcfr
2018-10-15 07:46 jcfr Status new => assigned
2018-10-15 07:53 jcfr Status assigned => resolved
2018-10-15 07:53 jcfr Resolution open => fixed
2018-10-15 07:53 jcfr Fixed in Version => Slicer 4.9.0
2018-10-15 07:53 jcfr Note Added: 0016129