View Issue Details

IDProjectCategoryView StatusLast Update
0004634Slicer4Module LandmarkRegistrationpublic2019-05-17 10:59
ReporterpieperAssigned Tosjh267 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.10.2Fixed in VersionSlicer 4.10.2 
Summary0004634: Most fiducials not selectable in LandmarkRegistration with latest VTK
Description

The fiducials used as landmarks cannot be selected in most cases. On maybe 1 in 6 few slice views it is possible to grab and move a fiducial, but on the others the default window/level operation is applied.

Steps To Reproduce

1) Open Slicer
2) load to volumes (e.g. download MRHead twice)
3) enter LandmarkRegistration module
4) select volumes as fixed and moving
5) add a landmark
6) try to grab and move the landmark in different slice views => you can in 4.8.1, but cannot in 4.9

Additional Information

This is related to the version of VTK used for Qt5 compatibility. If the same Slicer code is compiled for Qt4, then an older VTK is used and the landmarks are all draggable.

TagsNo tags attached.

Relationships

related to 0004628 closedjcfr Unable to move fiducial position with cursor 
related to 0003808 closednicole Impossible to move landmarks, on one, two or three of the slices 

Activities

jcfr

jcfr

2018-10-15 22:56

administrator   ~0016133

Last edited: 2018-10-15 23:58

View 2 revisions

This particular issue was already present in r27104 when the VTK version was updated to include fixed in VTK to avoid workaround associated with 0003808.

This can be verified by downloading the installer associated with r27120: https://download.slicer.org/bitstream/788001

jcfr

jcfr

2018-10-15 23:57

administrator   ~0016134

Last edited: 2018-10-15 23:59

View 3 revisions

On windows:

Installer associated with r27099:

Installer associated with r27105:

pieper

pieper

2018-11-21 14:43

administrator   ~0016198

Workaround is to pan before grabbing fiducials as describe here:

https://github.com/pieper/LandmarkRegistration/pull/24#issuecomment-440787136

sjh267

sjh267

2018-11-27 15:21

administrator   ~0016205

With the pan workaround as a clue, I can (sometimes) reproduce this without using the landmark registration module

  1. Load volume
  2. Place 1 or 2 fiducials
  3. In markups module, activate Jump to Slices and Centered
  4. Jump to a fiducial
  5. Try to move fiducial. It will usually be immovable in at least 1 view
pieper

pieper

2018-11-29 09:26

administrator   ~0016211

That's a huge help - thanks!

This will need some deep dive debugging to keep track of all the picker code and whatnot. In the previous version of this bug I spent several days on it. Getting a pure-VTK demo was key to getting it fixed that time and would be good this time too if we can do it.

sjh267

sjh267

2019-03-04 15:39

administrator   ~0016251

Working to get this fixed:



vtkPickingManagerBug2D.py (2,267 bytes)
jcfr

jcfr

2019-03-04 15:50

administrator   ~0016252

Last edited: 2019-03-04 15:50

View 3 revisions

Thanks for the update. This will be a good candidate for the 4.10.2 patch release.

Worth noting that since this morning, the widget changes of @lassoan and @Davide have been integrated into master. See r27974

sjh267

sjh267

2019-05-16 11:04

administrator   ~0016260

Last edited: 2019-05-16 11:04

View 2 revisions

Fix finalized in 4.10.2 release branch: http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=28255

Issue History

Date Modified Username Field Change
2018-10-15 18:16 pieper New Issue
2018-10-15 18:16 pieper Status new => assigned
2018-10-15 18:16 pieper Assigned To => pieper
2018-10-15 18:33 jcfr Relationship added related to 0004628
2018-10-15 20:46 jcfr Relationship added related to 0003808
2018-10-15 22:56 jcfr Note Added: 0016133
2018-10-15 23:57 jcfr Note Added: 0016134
2018-10-15 23:58 jcfr Note Edited: 0016134 View Revisions
2018-10-15 23:58 jcfr Note Edited: 0016133 View Revisions
2018-10-15 23:59 jcfr Note Edited: 0016134 View Revisions
2018-10-16 01:29 jcfr Target Version => Slicer 4.11.0
2018-11-21 14:43 pieper Note Added: 0016198
2018-11-27 15:21 sjh267 Note Added: 0016205
2018-11-29 09:26 pieper Note Added: 0016211
2019-01-16 16:29 jcfr Assigned To pieper => sjh267
2019-01-16 16:30 jcfr Target Version Slicer 4.11.0 => Slicer 4.10.2
2019-03-04 15:39 sjh267 File Added: vtkPickingManagerBug2D.py
2019-03-04 15:39 sjh267 Note Added: 0016251
2019-03-04 15:50 jcfr Note Added: 0016252
2019-03-04 15:50 jcfr Note Edited: 0016252 View Revisions
2019-03-04 15:50 jcfr Note Edited: 0016252 View Revisions
2019-05-16 11:04 sjh267 Note Added: 0016260
2019-05-16 11:04 sjh267 Note Edited: 0016260 View Revisions
2019-05-17 10:59 sjh267 Status assigned => closed
2019-05-17 10:59 sjh267 Resolution open => fixed
2019-05-17 10:59 sjh267 Fixed in Version => Slicer 4.10.2