View Issue Details

IDProjectCategoryView StatusLast Update
0004654Slicer4Core: Usabilitypublic2018-11-07 14:37
ReporterfedorovAssigned Topieper 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformmacOSOSOS Version
Product VersionSlicer 4.11.0 
Target VersionFixed in VersionSlicer 4.11.0 
Summary0004654: XCode required to **use** Slicer on mac
Description

I was helping a clinical researcher to set up 4.10 on mac, and I ran into the message asking to install git and XCode. Installing XCode is a long step that I would not expect to be required to use Slicer. I don’t think XCode was required in the past.

Apparently, we were able to proceed with “Not Now”, but it is not clear what (if any) functionality of Slicer would not be available due to this.

There is no mention of XCode requirements in the install instructions here: https://www.slicer.org/wiki/New_users#Installing_3D_Slicer 1

TagsNo tags attached.

Activities

lassoan

lassoan

2018-11-07 12:59

developer   ~0016190

Others have reported this and it is extremely annoying.

The problem is caused by ExtensionWizard, which calls import git, which in turns tries to run git version. This would expect to fail when git is not installed, but MacOS tries to be smart and shows a dialog box to the user(!) to install stuff. I guess this behavior on Mac will be fixed, but until then we should be able to move out all the import git calls from ExtensionWizard initialization steps. I'll commit a fix soon.

fedorov

fedorov

2018-11-07 13:01

developer   ~0016191

I suspected that was the reason!

How about disabling that module by default, and only showing it when "Developer mode" is enabled? This would be a very harmless and effective fix, IMHO.

lassoan

lassoan

2018-11-07 13:14

developer   ~0016192

It could be a good option, too, but there is no mechanism implemented yet for disabling certain modules when developer mode is disabled. I've now changed ExtensionWizard to call import git only when git it is actually needed. I already have a fix, just wait for a build to complete to confirm it all works well.

fedorov

fedorov

2018-11-07 13:18

developer   ~0016193

Ah, I see. I thought there was a mechanism, since it is possible to disable tests when not in dev mode. But your solution makes total sense. Thank you for fixing it!

lassoan

lassoan

2018-11-07 14:37

developer   ~0016194

Fix committed r27535

Issue History

Date Modified Username Field Change
2018-11-07 11:27 fedorov New Issue
2018-11-07 11:27 fedorov Status new => assigned
2018-11-07 11:27 fedorov Assigned To => pieper
2018-11-07 12:59 lassoan Note Added: 0016190
2018-11-07 13:01 fedorov Note Added: 0016191
2018-11-07 13:14 lassoan Note Added: 0016192
2018-11-07 13:18 fedorov Note Added: 0016193
2018-11-07 14:37 lassoan Status assigned => resolved
2018-11-07 14:37 lassoan Resolution open => fixed
2018-11-07 14:37 lassoan Fixed in Version => Slicer 4.11.0
2018-11-07 14:37 lassoan Note Added: 0016194