View Issue Details

IDProjectCategoryView StatusLast Update
0004671Slicer4Core: Base Codepublic2019-05-17 10:58
ReporterjcfrAssigned Tosjh267 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.10.2Fixed in VersionSlicer 4.10.2 
Summary0004671: Backport
Description

See https://www.slicer.org/wiki/Documentation/Nightly/Developers/ReleaseProcess#Backport_commit_into_release_branch

qSlicerWebWidget:

  • 27938: ENH: Update py_WebEngine self-test enabling python evaluation test
  • 27939: COMP: qSlicerWebPythonProxy: Exclude python eval if python is disabled
  • 27940: BUG: qSlicerWebWidget: Ensure WebChannel initialization is done for base class
  • 27941: ENH: Re-factor WebChannelTransport initialization
  • 27972: ENH: relay QWebEngineView signals to qSlicerWebWidget
  • 28185: ENH: add debug for python evaluation from webengine
  • 28187: ENH: qSlicerWebWidget: Remove debug statement

ExtensionBuildSystem:

  • 27942: BUG: ExtensionBuildSystemTest: Improve tests robustness
  • 27943: BUG: ExtensionBuildSystem: Fix build of extensions using Ninja generator
  • 27944: BUG: ExtensionBuildSystem: Fix issue preventing build of dependent extensions
TagsNo tags attached.

Activities

lassoan

lassoan

2019-05-14 10:04

developer   ~0016259

It would be great if we could backport these bugfixes, too:

Revision: a3cb76715f1158d5e0c1b17982ee7e1836e3fcc5
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 1/21/2019 1:21:41 PM
Message:
BUG: Fix distance encoded projection in Slice view

  • Implicit plane function for calculating distance uses SliceXYToRAS, however the distance is scaled in the Z direction
  • Fixed by normalizing the plane normal used for distance encoded projection

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27946 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/DisplayableManager/vtkMRMLModelSliceDisplayableManager.cxx
Modified: Modules/Loadable/Segmentations/MRMLDM/vtkMRMLSegmentationsDisplayableManager2D.cxx

Revision: 62c7fe246ca3a149d36bf15b4d9d01c9aa27c214
Author: jcfr <jcfr@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 1/26/2019 12:40:45 AM
Message:
BUG: Fix vtkMRMLCameraNode::ResetClippingRange

This commit fixes a regression introduced in r27297 (ENH: added 3d views
linking capability) where use of "vtkCommand::ResetCameraClippingRangeEvent"
was replaced by custom event "vtkMRMLCameraNode::ResetCameraClippingEvent"

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27948 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/Core/vtkMRMLCameraNode.cxx

Revision: 3195e6d0bcd3ef29e383294a9b4e7ba13dfa9469
Author: cpinter <cpinter@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 2/6/2019 4:16:32 PM
Message:
BUG: Fix multiple conversions when hardening transform on segmentation

When hardening segmentation on a segmentation node containing planar contour master and closed surface, the conversion was performed multiple times, so it seemed like the application hang. Disabling an event for the hardening operation fixes this issue.

A meaningless error message about the inability to get reference image geometry when there is no labelmap representation has been removed as well.

Fixes https://github.com/SlicerRt/SlicerRT/issues/102
Related to https://discourse.slicer.org/t/harden-transform-on-large-segmentation-hangs-3d-slicer/5643

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27953 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/Core/vtkMRMLSegmentationNode.cxx
Modified: Libs/vtkSegmentationCore/vtkSegmentation.h
Modified: Libs/vtkSegmentationCore/vtkSegmentationConverter.cxx

Revision: 0b13a3256492547d029be8e2a5f4afb42d30a693
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 2/8/2019 12:50:40 PM
Message:
BUG: Fixed restoring of deleted segments by Undo

In some cases Undo could not restore deleted segments.
See user error report: https://discourse.slicer.org/t/confirmation-or-undo-in-segment-editor/5694/14

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27954 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/vtkSegmentationCore/vtkSegmentationHistory.cxx

Revision: 2c39ac184feb665d0a1f229b9fa089656a45612a
Author: cpinter <cpinter@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 2/19/2019 12:14:46 PM
Message:
BUG: Fix export segmentation to file with illegal characters in node name

Re https://discourse.slicer.org/t/export-dicom-rt-structure-as-segmentation/5797

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27967 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Modules/Loadable/Segmentations/Logic/vtkSlicerSegmentationsModuleLogic.cxx
Modified: Modules/Loadable/Segmentations/Logic/vtkSlicerSegmentationsModuleLogic.h

Revision: 4f2e0807f311d7ba0ab8c494f81c0b9203490d5d
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/1/2019 11:56:09 AM
Message:
BUG: Fix mouse cursor in Segment Editor

Since recent updates in VTK Qt widget, when a Segment Editor effect was active the mouse cursor remained the default arrow cursor.
Fixed by adding setViewCursor() method that calls appropriate method to change the cursor shape, and calling this method from Segment Editor.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27971 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Base/QTGUI/qSlicerMouseModeToolBar.cxx
Modified: Libs/MRML/Widgets/qMRMLSliceView.cxx
Modified: Libs/MRML/Widgets/qMRMLSliceView.h
Modified: Libs/MRML/Widgets/qMRMLThreeDView.cxx
Modified: Libs/MRML/Widgets/qMRMLThreeDView.h
Modified: Modules/Loadable/Segmentations/EditorEffects/qSlicerSegmentEditorAbstractEffect.cxx
Modified: Modules/Loadable/Segmentations/Widgets/qMRMLSegmentEditorWidget.cxx

Revision: 0d7b9aee55293790d6c49fdbaa84991c7154d1a4
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/11/2019 2:34:08 AM
Message:
BUG: Fix crash after shutdown on mac/linux

Co-authored-by: Davide Punzo <punzodavide@hotmail.it>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28014 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Base/Python/slicer/ScriptedLoadableModule.py

Revision: 0a8e2d772f77d2a664b40fffd476e25f314e8f85
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/11/2019 2:34:02 AM
Message:
BUG: Prevent confirm close dialog from showing twice

This was due to a Mac-specific Qt bug (https://bugreports.qt.io/browse/QTBUG-43344). Fixed using a simple flag preventing the second event to be handled.

Co-authored-by: Csaba Pinter <csaba.pinter@queensu.ca>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28012 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Base/QTApp/qSlicerMainWindow.cxx
Modified: Base/QTApp/qSlicerMainWindow_p.h

Revision: c966c4890dadcfe1e4da418b0edda9b4e23236eb
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/10/2019 11:59:26 PM
Message:
BUG: Fixed resetting default mouse cursor in Segment editor

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28011 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/Widgets/qMRMLSliceView.cxx
Modified: Libs/MRML/Widgets/qMRMLSliceView.h
Modified: Libs/MRML/Widgets/qMRMLThreeDView.cxx
Modified: Libs/MRML/Widgets/qMRMLThreeDView.h
Modified: Modules/Loadable/Segmentations/Widgets/qMRMLSegmentEditorWidget.cxx

Revision: 724ed0fb8ff9b9fce1dad4c73ed0ece495a63870
Author: jcfr <jcfr@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/12/2019 8:14:44 PM
Message:
BUG: Fix errors for model slice display manager when not in slice plane

  • If there is no input or if the input has no points, the vtkTransformPolyDataFilter
    will display an error message on every update: "No input data".

  • To prevent the error, if the input is empty then the actor should not be visible
    since there is nothing to display.

This is a good workaround for these unnecessary VTK messages. A discussion was
also started on the VTK forum to remove these messages.
See https://discourse.vtk.org/t/logging-error-messages-for-empty-input-data/453

From: Kyle Sunderland <sunderlandkyl@gmail.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28018 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/DisplayableManager/vtkMRMLModelSliceDisplayableManager.cxx

Revision: d6280e5741d3fb4ba2f025a4483e07523ef8a553
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/15/2019 2:14:14 PM
Message:
BUG: Fixed image not filling entire slice view

In some cases, for example, after changing font scale on Windows10, images only filled the bottom-left corner of slice view.

Debugging revealed that devicePixelRatioF() returned 1.9999... while devicePixelRatio() returned 1. Using devicePixelRatioF to scale the view size fixed the issue.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28025 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/Widgets/qMRMLSliceWidget.cxx

Revision: d81595347e274ab7d2cd97665573b4c8311a6908
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/27/2019 2:02:24 PM
Message:
BUG: Fixed Segment Editor Show 3D button state

In some cases (when first segment was not the first segment alphabetically), Show 3D button had to be clicked twice to actually hide the segmentation.

The problem was that segmentation removed closed surface representation one by one starting from the first segment in the segment map (alphabetically), and after each removal, a display update was triggered. The displayable manager checked representation of the first segment in the segment list (not necessarily ordered alphabetically), and recreated all missing representations. Displayable manager's assumption that all segments have the same representation was not valid because segment modified events were invoked while some of not all segments had the same representations.

Fixed the issue by not invoking segment modified events until all the segments have the same representations.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28059 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/vtkSegmentationCore/vtkSegment.cxx
Modified: Libs/vtkSegmentationCore/vtkSegment.h
Modified: Libs/vtkSegmentationCore/vtkSegmentation.cxx
Modified: Libs/vtkSegmentationCore/vtkSegmentation.h

Revision: 08a67d8a16467353892a967be553d1dff3da1efd
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/27/2019 4:43:10 PM
Message:
BUG: Fixed volume rendering is not visible

Problem was that there were multiple volume rendering display nodes in the scene and the first one was invalid (there was not volume associated with it). Even though the user enabled visibility, the volume was not rendered because of the missing volume node association.

Fixed by ignoring corrupted display nodes.

User who created the offending scene reported that only Slicer GUI was used, therefore the root cause of the problem (having two volume rendering display nodes, one of them is invalid) is not addressed by this commit.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28060 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Modules/Loadable/Segmentations/Widgets/qMRMLSegmentEditorWidget.cxx
Modified: Modules/Loadable/VolumeRendering/Logic/vtkSlicerVolumeRenderingLogic.cxx

Revision: 89de5b3770fa6908ee71495f96f2080662438ee1
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/27/2019 11:25:30 PM
Message:
BUG: Fix warning when exporting segmentation to labelmap

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28063 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Modules/Loadable/Segmentations/Logic/vtkSlicerSegmentationsModuleLogic.cxx

Revision: 32d2f96fa19876de319fa9b75aac56754a90ab5d
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 3/27/2019 11:25:36 PM
Message:
BUG: Prevent SegmentStatistics crash for invalid input

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28065 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Modules/Scripted/LabelStatistics/LabelStatistics.py
Modified: Modules/Scripted/SegmentStatistics/SegmentStatisticsPlugins/LabelmapSegmentStatisticsPlugin.py
Modified: Modules/Scripted/SegmentStatistics/SegmentStatisticsPlugins/ScalarVolumeSegmentStatisticsPlugin.py

Revision: 7ea34865ccc330bda78a6b75bb0fe407445934f5
Author: jcfr <jcfr@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 4/10/2019 10:55:37 AM
Message:
BUG: vtkMRMLScalarBarDisplayableManager: Ensure scalar bar is up-to-date

This commit fixes -Wempty-body warning

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28097 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/DisplayableManager/vtkMRMLScalarBarDisplayableManager.cxx

Revision: 910376055ac44f69bbdca3f96993691a957036ff
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 4/15/2019 12:28:54 AM
Message:
BUG: Fixed loading of segmentation from generic nrrd file

Segmentation could not be loaded directly from a generic nrrd file (that did not have any segmentation specific fields) because segment name was not filled and uninitialized segment name caused a crash.

Fixed by using segment ID as segment name if segment name is not specified.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28139 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Libs/MRML/Core/vtkMRMLSegmentationStorageNode.cxx
Modified: Modules/Loadable/Segmentations/SubjectHierarchyPlugins/qSlicerSubjectHierarchySegmentationsPlugin.cxx

Revision: 2fe008bc58f762772bf92f5ec019ff5aa512db05
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 5/8/2019 10:19:04 PM
Message:
BUG: Fixed Data probe for scenes with custom slice view names

sliceWidget() method expects slice node name and not layout name.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28216 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Modules/Scripted/DataProbe/DataProbe.py

Revision: 05b9129eb779cc163110725485d7bfab3ac3f0f6
Author: lassoan <lassoan@3bd1e089-480b-0410-8dfb-8563597acbee>
Date: 5/11/2019 12:11:19 AM
Message:
BUG: Make DICOMScalarVolumePlugin more robust for multi-frame volumes

Prevent throwing an error when examining slice positions in a multi-frame DICOM file (just log a warning).

git-svn-id: http://svn.slicer.org/Slicer4/trunk@28225 3bd1e089-480b-0410-8dfb-8563597acbee

Modified: Modules/Scripted/DICOMPlugins/DICOMScalarVolumePlugin.py

sjh267

sjh267

2019-05-17 10:58

administrator   ~0016261

Backporting into 4.10.2 completed

Issue History

Date Modified Username Field Change
2019-01-16 16:32 jcfr New Issue
2019-01-16 16:32 jcfr Status new => assigned
2019-01-16 16:32 jcfr Assigned To => sjh267
2019-01-16 16:33 jcfr Description Updated View Revisions
2019-01-18 00:38 jcfr Description Updated View Revisions
2019-04-26 13:43 jcfr Description Updated View Revisions
2019-04-26 13:43 jcfr Description Updated View Revisions
2019-04-26 15:08 jcfr Description Updated View Revisions
2019-05-14 10:04 lassoan Note Added: 0016259
2019-05-17 10:58 sjh267 Status assigned => closed
2019-05-17 10:58 sjh267 Resolution open => fixed
2019-05-17 10:58 sjh267 Fixed in Version => Slicer 4.10.2
2019-05-17 10:58 sjh267 Note Added: 0016261