View Issue Details

IDProjectCategoryView StatusLast Update
0004674Slicer4Core: Building (CMake, Superbuild)public2019-02-07 21:44
ReporterphcerdanAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
Product VersionSlicer 4.11.0 
Target VersionSlicer 4.11.0Fixed in Version 
Summary0004674: Slicer_VERSION set in the top CMakeLists do not update version in Slicer-build at Superbuild
Description

I was using tip of master (Slicer_VERSION 4.11.0), but the version of the internal Slicer-build was set to 4.9 from an old build.
The result is that I have two folders after the build: Slicer-build/lib/Slicer-4.11 and Slicer-build/lib/Slicer-4.9

Removing the cache in Slicer-build/CMakeCache.txt solves the problem, but clearing caches should not be needed.

I guess a possible solution would be to pass the version computed in the top CMakeListst.txt to the "external project" Slicer.

Here: https://github.com/Slicer/Slicer/blob/master/SuperBuild.cmake#L523-L552

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-02-07 21:32 phcerdan New Issue
2019-02-07 21:32 phcerdan Status new => assigned
2019-02-07 21:32 phcerdan Assigned To => jcfr
2019-02-07 21:41 phcerdan Description Updated View Revisions
2019-02-07 21:44 phcerdan Description Updated View Revisions