View Issue Details

IDProjectCategoryView StatusLast Update
0004689Slicer4Module Markupspublic2019-06-20 20:11
ReporterlassoanAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.11.0 
Target VersionSlicer 4.11.0Fixed in VersionSlicer 4.11.0 
Summary0004689: Markup labels not always visible in tall views
Description

In views that are much taller than wide, markup fiducial labels are not always visible. For example, they may not be visible in the left side of the view.

More information: https://discourse.slicer.org/t/labels-for-fudicial-markups-not-appearing-until-5th-6th-fiducial-is-placed-4-11-0/6559/4

TagsNo tags attached.

Activities

lassoan

lassoan

2019-05-21 12:53

developer   ~0016262

This is caused by a bug in VTK. A fix is submitted to VTK (https://gitlab.kitware.com/vtk/vtk/merge_requests/5567), it should get into Slicer within 1-2 weeks.

lassoan

lassoan

2019-06-02 15:26

developer   ~0016267

Fix was merged into VTK: https://gitlab.kitware.com/vtk/vtk/commit/f24894b791580e7efbe4d2dc316111951e261e13

@jcfr Could you merge the fix into Slicer's VTK? Thank you!

lassoan

lassoan

2019-06-20 11:57

developer   ~0016270

@jcfr it would be great if you could backport the mentioned fix into Slicer's VTK. Thanks!

jcfr

jcfr

2019-06-20 20:11

administrator   ~0016271

Changes backported in r28321

Issue History

Date Modified Username Field Change
2019-04-24 18:22 lassoan New Issue
2019-04-24 18:22 lassoan Status new => assigned
2019-04-24 18:22 lassoan Assigned To => lassoan
2019-05-21 12:53 lassoan Note Added: 0016262
2019-06-02 15:26 lassoan Note Added: 0016267
2019-06-20 11:57 lassoan Assigned To lassoan => jcfr
2019-06-20 11:57 lassoan Note Added: 0016270
2019-06-20 20:11 jcfr Status assigned => resolved
2019-06-20 20:11 jcfr Resolution open => fixed
2019-06-20 20:11 jcfr Fixed in Version => Slicer 4.11.0
2019-06-20 20:11 jcfr Note Added: 0016271