View Issue Details

IDProjectCategoryView StatusLast Update
0004694Slicer4Module Markupspublic2019-07-04 13:52
ReporterfepegarAssigned Tolassoan 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformmacOSOSSierraOS Version
Product Version 
Target VersionFixed in VersionSlicer 4.11.0 
Summary0004694: Slicer crashes when deleting Markups node
Description

Slicer crashes when deleting Markups node.

Steps To Reproduce

1) Place a fiducial
2) Go to Markups module
3) Click on Delete current node

Additional Information
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - Session start time .......: 2019-05-22 15:18:49
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - Slicer version ...........: 4.11.0-2019-05-21 (revision 28261) macosx-amd64 - installed release
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - Operating system .........: Mac OS X / 10.12.6 / 16G1314 - 64-bit
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - Memory ...................: 8192 MB physical, 2048 MB virtual
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - CPU ......................: GenuineIntel Intel(R) Core(TM) i5-4278U CPU @ 2.60GHz, 2 cores, 4 logical processors
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - VTK configuration ........: OpenGL2 rendering, Sequential threading
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - Developer mode enabled ...: yes
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - Prefer executable CLI ....: yes
[DEBUG][Qt] 22.05.2019 15:18:49 [] (unknown:0) - Additional module paths ..: (none)
[DEBUG][Python] 22.05.2019 15:18:52 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: Annotations
[DEBUG][Python] 22.05.2019 15:18:54 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentEditor
[DEBUG][Python] 22.05.2019 15:18:54 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentStatistics
[DEBUG][Qt] 22.05.2019 15:18:55 [] (unknown:0) - Switch to module:  "Data"
[INFO][Stream] 22.05.2019 15:18:57 [] (unknown:0) - Loading Slicer RC file [/Users/fernando/.slicerrc.py]
[INFO][Stream] 22.05.2019 15:18:57 [] (unknown:0) - Slicer RC file loaded [22/05/2019 14:18:57]
[DEBUG][Qt] 22.05.2019 15:18:57 [] (unknown:0) - "Color" Reader has successfully read the file "/Users/fernando/git/EpiNav/MITK/Modules/Core/Resources/BrainAnatomyLabelsV3_0.txt" "[0.03s]"
[CRITICAL][Qt] 22.05.2019 15:19:03 [] (unknown:0) - virtual QColor qSlicerSubjectHierarchyMarkupsPlugin::getDisplayColor(vtkIdType, QMap<int, QVariant> &) const : No display node
[DEBUG][Qt] 22.05.2019 15:19:08 [] (unknown:0) - Switch to module:  "Markups"
TagsNo tags attached.

Activities

lassoan

lassoan

2019-07-04 13:52

developer   ~0016276

The issue is not reproducible anymore.

Issue History

Date Modified Username Field Change
2019-05-22 10:26 fepegar New Issue
2019-05-22 10:26 fepegar Status new => assigned
2019-05-22 10:26 fepegar Assigned To => nicole
2019-07-04 13:52 lassoan Assigned To nicole => lassoan
2019-07-04 13:52 lassoan Status assigned => resolved
2019-07-04 13:52 lassoan Resolution open => fixed
2019-07-04 13:52 lassoan Fixed in Version => Slicer 4.11.0
2019-07-04 13:52 lassoan Note Added: 0016276