View Issue Details

IDProjectCategoryView StatusLast Update
0000048Slicer3GUIpublic2008-06-27 06:47
ReporterpieperAssigned Tobarre 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
PlatformwindowsOSOS Version
Summary0000048: alt-f-x crash
Description

Using Alt-F X to exit slicer3 on windows causes the file menu to stay posted while the main app goes away. Clicking the Exit option of the disembodied menu makes the program quit, but generates the error messages posted below.

Additional Information

ERROR: In ..\KWWidgets\vtkKWApplication.cxx, line 1173
vtkSlicerApplication (0708E028): TclTk error: can't create window: parent has been destroyed
can't create window: parent has been destroyed
while executing
"tk::label $w -borderwidth 0 -height 0 -highlightthickness 0 -padx 0 -pady 0 -relief flat -takefocus 0"
(procedure "::tablelist::displayImage" line 10)
invoked from within
"::tablelist::displayImage .vtkKWLogDialog20.vtkKWLogWidget21.vtkKWMultiColumnListWithScrollbars30.vtkKWMultiColumnList33 k0 1 16"

ERROR: In ..\KWWidgets\vtkKWApplication.cxx, line 1173
vtkSlicerApplication (0708E028): TclTk error: can't create window: parent has been destroyed
can't create window: parent has been destroyed
while executing
"tk::label $w -borderwidth 0 -height 0 -highlightthickness 0 -padx 0 -pady 0 -relief flat -takefocus 0"
(procedure "::tablelist::displayImage" line 10)
invoked from within
"::tablelist::displayImage .vtkKWLogDialog20.vtkKWLogWidget21.vtkKWMultiColumnListWithScrollbars30.vtkKWMultiColumnList33 k1 1 16"

ERROR: In ..\KWWidgets\vtkKWApplication.cxx, line 1173
vtkSlicerApplication (0708E028): TclTk error: can't create window: parent has been destroyed
can't create window: parent has been destroyed
while executing
"tk::label $w -borderwidth 0 -height 0 -highlightthickness 0 -padx 0 -pady 0 -relief flat -takefocus 0"
(procedure "::tablelist::displa

TagsNo tags attached.

Activities

pieper

pieper

2007-03-27 11:14

administrator   ~0000072

Seems to be fixed.

barre

barre

2007-03-28 08:56

developer   ~0000081

I can not reproduce on Unix or Window.
It seems the log widget was involved, so I tried to injecting errors to eventually trigger a reference loop from the log widget, but that did not work, the app would still exit properly.

pieper

pieper

2007-11-20 10:29

administrator   ~0000168

This was/is related to the VTK Fly-To feature of the Interactor. I'll check if this is still an issue.

barre

barre

2008-06-27 06:47

developer   ~0000370

Fixed a while ago in KWW

Issue History

Date Modified Username Field Change
2007-03-20 06:20 pieper New Issue
2007-03-20 06:20 pieper Status new => assigned
2007-03-20 06:20 pieper Assigned To => barre
2007-03-27 11:14 pieper Note Added: 0000072
2007-03-27 11:14 pieper Resolution open => suspended
2007-03-27 11:14 pieper Additional Information Updated
2007-03-28 08:56 barre Note Added: 0000081
2007-11-20 10:29 pieper Note Added: 0000168
2008-06-27 06:47 barre Status assigned => closed
2008-06-27 06:47 barre Note Added: 0000370