View Issue Details

IDProjectCategoryView StatusLast Update
0000059Slicer3GUIpublic2007-08-20 05:15
ReporterleueAssigned Towjp 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Summary0000059: Slicer3 does not remember its window size from session to session
Description

Slicer3 always opens with the same window size, regardless of what the window has been resized to during the previous session. User expectations for Windows software is that programs should remember their previous window size and restore it when restarted.

A related issue is that the window size that Slicer3 uses on startup is poorly chosen -- the height is always too large and some of the bottom of the window is hidden off screen.

Additional Information

Windows XP, SP2 and all current patches.

TagsNo tags attached.

Activities

hayes

hayes

2007-05-21 09:20

administrator   ~0000099

There is some capability to save session information in the Windows registry and in a dotfile for Linux. Perhaps this information could be added as well.

Regarding the startup Window size -- Slicer3 is best viewed at 1280x1024 resolution. If you are using a lower resolution than that, it could be the cause of the problems you're seeing. It's a known limitation that we are currently trying to fix.

wjp

wjp

2007-08-20 05:15

administrator   ~0000115

Slicer3 should remember and restore some aspects of its geometry and layout now, like the window size and the layout of 3D and Slice Viewers. There are additional things about its layout (like whether the GUI panel is open, and whether the sliceGUI panel is collapsed) that this fix won't address in every case -- I'll put these modifications off until later.

Issue History

Date Modified Username Field Change
2007-05-17 12:16 leue New Issue
2007-05-21 09:20 hayes Note Added: 0000099
2007-05-21 09:20 hayes Severity minor => feature
2007-05-21 09:20 hayes Status new => acknowledged
2007-05-21 09:20 hayes Category Base Code => GUI
2007-08-15 12:28 pieper Assigned To => wjp
2007-08-20 05:15 wjp Note Added: 0000115
2007-08-20 05:15 wjp Status acknowledged => resolved
2007-08-20 05:15 wjp Resolution open => fixed