View Issue Details

IDProjectCategoryView StatusLast Update
0000009Slicer3Base Codepublic2017-06-10 08:51
ReporterkikinisAssigned Tojcfr 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Summary0000009: fg/bg threshold issue with SPL atlas
Description

Volume display threshold is broken. t1 in f t2 in b thresold to auto makes t2 visible even if t was supposed to be. Histogram is not shown. (Reported by Ron)

TagsNo tags attached.

Activities

pieper

pieper

2007-01-19 12:10

administrator   ~0000006

Probably already fixed by Alex. Can you confirm with a new build?

alexy

alexy

2007-01-24 06:20

developer   ~0000010

I fixed a similar bug reported by Brad Davis at AHM. Please reopen if you see this behavior again.

hayes

hayes

2007-01-29 12:34

administrator   ~0000027

Waiting on Ron to confirm before closing the bug.

hayes

hayes

2007-01-30 09:10

administrator   ~0000028

Ron confirms that this bug is fixed. Closing the bug...

jcfr

jcfr

2017-06-07 23:27

administrator   ~0014570

Fix committed to 2145-support-for-installing-extension-from-file branch.

Related Changesets

Slicer: 2145-support-for-installing-extension-from-file 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Import 2017-06-07 23:51:09: master 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Issue History

Date Modified Username Field Change
2007-01-19 06:40 hayes New Issue
2007-01-19 06:52 hayes Reporter hayes => kikinis
2007-01-19 06:52 hayes Priority high => normal
2007-01-19 12:10 pieper Note Added: 0000006
2007-01-19 12:10 pieper Assigned To => alexy
2007-01-19 12:10 pieper Status new => confirmed
2007-01-24 06:20 alexy Status confirmed => resolved
2007-01-24 06:20 alexy Resolution open => fixed
2007-01-24 06:20 alexy Note Added: 0000010
2007-01-29 12:34 hayes Note Added: 0000027
2007-01-30 09:10 hayes Note Added: 0000028
2007-01-30 09:10 hayes Status resolved => closed
2017-06-07 23:27 jcfr Changeset attached => Slicer 2145-support-for-installing-extension-from-file 29a04b80
2017-06-07 23:27 jcfr Note Added: 0014570
2017-06-07 23:27 jcfr Assigned To alexy => jcfr
2017-06-10 08:51 jcfr Changeset attached => Slicer master 29a04b80